Як включити Flash Player в Google Chrome версії і вище 42

Днями я порушив святе правило адмінів — «Якщо нормально працює — не чіпай» і оновив веб-браузер Google Chrome до останньої на сьогоднішній день стабільної версії — 42.0. Після цього я виявив що не відтворюється більшість відео-роликів, не працюють онлайн-плеєри, навіть музика ВКонтакте грати відмовилася, пославшись на відсутність плагіна Флеш Плеєра. Я дуже здивувався, адже в Хромі він взагалі йде як вбудований модуль, окремої установки не вимагає і оновлюється автоматично. Але все-такі поліз на сайт adobe.com, скачав і поставив останню версію плагіна. Перевіряю — знову ролики не відтворюються, музика не грає. Це спантеличило ще сильніше і я знову поліз на офіційний сайт Adobe, де побачив ось таке повідомлення: «Програвач Adobe Flash Player вже встановлено, але відключений».

Дуже цікаво. Гаразд, давайте включимо його. Заходжу на сторінку встановлених плагінів Хрому ввівши в адресному рядку Chrome://plugins, і бачу ось таку картину:

Плагіна Flash Player в Google Chrome взагалі немає. Тут я смутно пригадую що проскакувала новина про те, що Гугл хоче відмовитися від Флеша на користь HTML5. Став копати в цьому напрямку і з’ясував ось що виявляється розробники браузера вирішили відмовитися від підтримки API Netscape Plugin, який використовується для установки багатьох плагінів у веб-браузери. У їх число потрапили якраз Adobe Flash, Java і Silverlight і Unity Web Player.

Що ж — тепер відмовлятися від улюбленого браузера? Ні, поки що не варто поспішати, враховуючи що з цим зіткнутися і багато інші браузери на платформі Хрому (SRWare Iron, SlimJet, Яндекс.Браузер тощо) теж зіткнутися з цією проблемою. До осені цього року можна знову включити підтримку NPAPI і користуватися плагінами. Для цього в рядок адреси вводимо:

chrome://flags/#enable-npapi

Відкриється ось таке вікно:

Натискаємо на посилання «Включити» для NPAPI. Після цього треба перезапустити браузер і знову зайти в Chrome://plugins:

Як бачите, Flash Player в Chrome з’явився знову. Але і це ще не все. Обов’язково поставте для нього галочку «Запустити завжди»:

Інакше, при спробі перегляду ролика Ви можете отримати повідомлення «Для роботи плагіна Flash Player вимагається дозвіл». Цього лякатися не варто, так як Гугл вважає цей застарілим і не підтримуваним і від того блокує його.
На жаль, це рішення буде актуально відносно недовго. Як я вже сказав вище, з вересня 2015 року підтримка NPAPI буде остаточно відключена.

 

Related posts

 
 

Leave a Reply

Ваш e-mail не будет опубликован. Обязательные поля помечены *

http://poradumo.com.ua/38941-iak-vkluchiti-flash-player-v-google-chrome-versiyi-i-vishe-42/